Vulnerable PHP Functions…

May 26, 2010 at 2:06 pm (LFI / RFI, PHP, Programming, Security)

Hey all,

Just a quick note, here is a list of vulnerable PHP functions that you should look out for in your web apps:

Local / Remote file inclusion bugs:

include()
include_once()
require()
require_once()

Local / Remote command execution bugs:

eval()
preg_replace()
fwrite()
passthru()
file_get_contents()
shell_exec()
system()

SQL Injection bugs:

mysql_query()

File / File system bugs:

fopen()
readfile()
glob()
file()
popen()
exec()

For auditing PHP based applications grep is pretty good however the ultimate tool is PHPXRef, which you can check out here.

Advertisements

5 Comments

  1. pearl said,

    I just wanted to thank you for such an informative documment 🙂

  2. Linux007 said,

    nice man,good work….

  3. ugit said,

    awesome brother thank you for sharing

  4. Parinita Master said,

    You certainly outdid yourself with this. I’m seriously impressed

  5. http://wordxs.com said,

    There is certainly a great deal to find out about this subject.
    I really like all the points you have made.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: